
Complete Network Outage
Started 20 Oct at 11:50pm BST, last updated 21 Oct at 07:45am BST.
Updated
Our backup connection has now been restored. Both connections, Primary & Backup are now working as usual.
We apologise for any disruption caused
Resolved
We have received an update on the outage via our Manchester connection. There is damage to the fiber connection between Machester and Leeds. Virgin Media has deployed engineers to find and repair the issue.
Our Primary connection via London Harbour Exchange has been restored and our Datacentre is now connected. At this moment our network is still at risk but we do not expect any further disruption.
Further updates will be issued once available.
Apologies for any incontinence caused

Created
Our Primary Newcastle datacentre is suffering a network outage due to the ongoing hardware failure at London Harbour Exchange and an unknown fault within our backup connection via Manchester.
Further details will be available in due course. Please click this announcement to view updates.